0

I have taken a data file using arduino and ov7670 camera module. In this project I used the famous code https://github.com/ComputerNerd/ov7670-no-ram-arduino-uno . But after taking the datafile ov7670NoRam.hex, I can't open it. I spent 3 hours to search how to open, but failed.

Could anyone please let me know how to have a look the image in .hex? or would it be possible to take image data from ov7670 directly to jpg?

I tried to convert the hex file to bin using hex2bin, but when I opened the bin, only errors occurred.

The following is the content of the ov7670NoRam.hex

:100000000C9436000C944B000C944B000C944B0059
:100010000C944B000C944B000C944B000C944B0034
:100020000C944B000C944B000C944B000C944B0024
:100030000C944B000C944B000C944B000C944B0014
:100040000C944B000C944B000C944B000C944B0004
:100050000C944B000C944B000C944B000C944B00F4
:100060000C944B000C944B005244590011241FBEB9
:10007000CFEFD8E0DEBFCDBF12E0A0E0B1E0EAE70D
:10008000F2E002C005900D92A235B107D9F70E94A7
:10009000AF000C943B010C9400008093BB0084E8FB
:1000A0008093BC008091BC0087FFFCCF8091B90099
:1000B000887F90E070E08617970709F408950E9402
:1000C000A00084EA8093BC008091BC0087FFFCCF35
:1000D0008091B900887F883009F408950E94A000BB
:1000E000CF93DF93D82FC62F0E94610068E182E48E
:1000F0000E944D0068E28D2F0E944D0068E28C2F17
:100100000E944D0084E98093BC008FE99FE0019735
:10011000F1F700C00000DF91CF910895CF93DF93F6
:10012000EC0103C00E9470002296FE01849131967A
:1001300064918F3FB9F76F3FA9F7DF91CF91089591
:10014000259A90E285B1892785B92FEF31EE84E0B9
:10015000215030408040E1F700C00000F3CFF89418
:10016000239A8091B6008F798093B60083E48093C0
:10017000B00089E08093B1001092B30087B1807F16
:1001800087B98AB183708AB92FEF8BE792E9215042
:1001900080409040E1F700C000008091B9008C7F62
:1001A0008093B90088E48093B8001092C50081E084
:1001B0008093C4008091C00082608093C00088E179
:1001C0008093C10086E08093C20060E882E10E94D3
:1001D00070002FEF81EE94E0215080409040E1F7D5
:1001E00000C0000080E091E00E948E0060E285E1A6
:1001F0000E94700060E08CE00E9470008AE392E050
:100200000E948E0088E492E00E948E0069E181E104
:100210000E947000E8E6F0E094918091C00085FFB4
:10022000FCCF9093C6008091C00085FFFCCF319633
:1002300084918111F1CF4B9BFECF4B99FECF40EEC5
:1002400051E08FE792E04A99FECF36B129B1207F85
:100250003F70232B2093C6004A9BFECF9C01215068
:100260003109892B11F0C901EECF415051094115D7
:0A027000510539F7CFCFF894FFCF06
:10027A0012803A0412001713180132B619021A7AB8
:10028A00030A0C003E00703A7135721173F0A20134
:10029A0015027A207B107C1E7D357E5A7F69807616
:1002AA0081808288838F849685A386AF87C488D706
:1002BA0089E813C0000010000D401418A505AB070B
:1002CA002495253326E39F78A068A103A6D8A7D84A
:1002DA00A8F0A990AA9413C5300031000E610F4B03
:1002EA0016021E07210222912907330B350B371DEF
:1002FA003871392A3C784D404E20690074108D4F70
:10030A008E008F009000910096009A00B084B10C84
:10031A00B20EB382B80A430A44F045344658472815
:10032A00483A59885A885B445C675D495E0E6C0A94
:10033A006D556E116F9E6A400140026013C74F806F
:10034A00508051005222535E5480589E41083F000B
:10035A00750576E14C0077013D484B09C960564066
:10036A0034113B12A48296009730982099309A84CF
:10037A009B299C039D4C9E3F78047901C8F0790F14
:10038A00C8007910C87E790AC880790BC801790C2F
:10039A00C80F790DC8207909C8807902C8C07903C5
:1003AA00C8407905C8307926FFFF32F617131801BD
:1003BA0019021A7A030AFFFF12013D08413D76E14C
:0203CA00FFFF33
:00000001FF

2 Answers 2

0

What is it you hope to achieve by "opening" the hex file or "converting it to binary"?

A hex file is a compiled sketch. It is intended to be installed into the Arduino Uno using avrdude.

4
  • ...you mean that it is not an image data? Oh.... I misunderstood. Because it was generated after the 'make write flash' I thought that it is the image. Thank you a lot for informing it.
    – Nownuri
    Jun 4, 2015 at 15:25
  • But could you please let me know how I can get an image...? I know it is a stupid question, but I have no idea how to take it now.
    – Nownuri
    Jun 4, 2015 at 15:26
  • It looks like you open the serial port on your computer, and the image data arrives. From my initial glance at the code it looks like you get the marker "RDY" between frames.
    – Majenko
    Jun 4, 2015 at 15:56
  • If I type 'make write flash', then does the image arrive? Or is it just installation and the should I do something to run the code?
    – Nownuri
    Jun 5, 2015 at 3:50
0

I am the author of the code and needless to say I am very confused right now on what you are trying to do. You run make writeflash in order to do what the target names implies write the hex file to microcontroller's internal flash memory. After that is done the code will run and you will use my frame grabber https://github.com/ComputerNerd/simpleFrameGrabber to capture an image.

1
  • Thank you for your answer. I misunderstood what the hex file is. But now I can't capture any image too. After running your simpleframegrabber I only see a black screen, even my oscilloscope shows that the ports D0~D7 are giving output signal. I set baud rate of the camera to be 9600 and then changed baud rate of the simpleframegrabber to be 9600 too. However it doesn't work. Even I tried opening IDE and then checked serial monitor which shows nothing. Could you please let me know what the problem would be?
    – Nownuri
    Jun 23, 2015 at 13:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.