1

hej guys,

recently I upgraded to Arduino's 1.6.4 IDE just to find out, that I can't seem to upload anything to my board. More specifically: The 1.6.4 IDE is not giving me the option to select the /tty/ board from the serial port list. I am avid Sublime Text 2 user, so obviously I tried to select the port in Stino and voilá: I was able to upload it to my boards.

Since I wanted to sort out if this is a software or hardware problem, I started to experiment with all my boards:

(all of them official boards, no clones)

  • 2 x Arduino Micro
  • 1 x Arduino Uno r3
  • 1 x Arduino Duemillanove
  • 1 x Arduino Mega 2560 r3
  • 12 x Teensy 3.1
  • a bunch of different USB cables.

none of these boards were registered by the Arduino 1.6.4 IDE, even after restarting the software and the computer several times. i'd only get this in my port selection: serial ports only showing /cu/

funny enough, my terminal told me the /tty/ device was there. here with the uno connected:

Dash:~ julianh$    ls /dev/tty.*
/dev/tty.Bluetooth-Incoming-Port
/dev/tty.Bluetooth-Modem
/dev/tty.usbmodemfa131

I also tried to re-install FTDI drivers, with no results.

only when I installed the old (trusty) 1.6.1 version, I was able to upload again.

all of the boards are also working fine. I just used my uno and mega another machine a few days ago for some side projects.

can someone confirm this problem with the new IDE 1.6.4 on OSX Yosemite 10.10.3? or is there any solution available online?

thanks!

  • What exactly happened when you tried to upload with the cu.* device? – Majenko May 31 '15 at 22:34
-1

I had the same problem when updated to 1.6.4, but with a Spark fun Pro micro. Did a "reset to bootloader" on the pro micro, and hit upload, and it worked out nice and it still does!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.