0

I have tried to connect a GSM dongle to a Intel Galileo Gen2 board and test the functionality of sending and receiving SMS through it.I know that it is easier to use a GSM shield to do above, but I'm currently doing a project in the way i mentioned above.Basically in Linux, we should know the serial port(like ttyACM0 in /dev directory) correspond to the device to communicate with it(Using AT commands).

but when i tried it in Galileo board it doesn't show such a serial port.but it detect device because lsusb command shows the device.

does anyone can help me to solve this matter?

  • It may detect it as a USB device, but does it know what it is? Check dmesg when you plug it in, and also run usb-devices to see if it has a driver attached. – Majenko May 31 '15 at 16:08
  • 1
    Many of these have to be kicked out of their initial mode of emulating a CD rom with windows drivers into a different mode which exposes USB-serial like devices. There's a program called usbmodeswitch which sends the necessary SCSI commands. This is probably off topic for the arduino site. – Chris Stratton May 31 '15 at 17:27
1

Try updating the firmware. I'm not sure if this affects also ACM type serial ports, but the initial version of the firmware was not even creating standard /dev/ttySx, rather some weird proprietary interface. Luckily this was fixed later on. So, in case you are still running the FW that the board came with, chances are you are having these weird serial ports.

  • In case my previous observation doesn't help, check the udev rules. It might simply miss the one for creating the appropriate type of character device. – Igor Stoppa May 31 '15 at 17:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.