3

A few days ago, I've asked this question. Thanks to the replies I've received, I've set up a cross compile environment for Yun by following this guide.
I've created a virtual machine with virtualbox and installed Debian 8.0 on it. I installed all the software required to download and compile the OpenWRT-Attitude Adjustment version (which, I think, is the version used by Arduino Yun) on Debian.
So, I've downloaded the OpenWRT source code, downloaded its packages feed (with "git clone git://git.openwrt.org/12.09/packages.git"), downloaded and installed all available "feeds" (with: "./scripts/feeds update -a" "./scripts/feeds install -a") and then compiled it with: "make defconfig" "make prereq" and "make menuconfig".
When I typed in "make menuconfig", a graphical interface prompted. In that interface I selected:
Target System: (Atheros AR7xx/AR9xx);
Base System: I selected libc, libcc and marked as package libpthread and librt.
I left any other option as default. Then I compiled all with "time make V=99" command.
After about 2 hours, the compiling finished and I set the environment variables as the above mentioned guide described.
Looks like now I can compile any C code with this cross-compiler. Anyway, my application includes the png.h header in order to use the libpng library, and every time I try to cross-compile it, a "png.h not found" error pops up during the process.
So I tried to cross-compile the libpng library but when I ran "./configure" with the options for cross-compiling, it failed saying that zlib wasn't installed. So I downloaded the zlib library source code but looks like I can't cross-compile it.
Eventually I compiled zlib and libpng normally on Debian and now, when I try to cross-compile my application, it still says that it can't find png.h... So, how can I "integrate" the libpng library to the cross-compiling environment?
Sorry for this long question, but it is all I've done today.
As always, I thank you for any help you can give me.

1
  • 1
    I'm voting to close this question as off-topic because it's more than 2 years old and have no answers.
    – user31481
    Oct 24, 2017 at 14:46

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.