38

I have a MacBook Pro running OS X Yosemite (10.10.3). I connected my Arduino UNO R3 to my computer for the first time after the Yosemite upgrade - it worked fine before this!

When I opened the Arduino IDE I selected Tools > Board > "Arduino UNO", but when I try to choose a Serial Port the only options are:

/dev/tty.Bluetooth-Incoming-Port
/dev/cu.Bluetooth-Incoming-Port
/dev/tty.Bluetooth-Modem
/dev/cu.Bluetooth-Modem

I have followed several tutorials and threads on how to 'fix' this issue, all to no avail:

I've installed the latest version of the FTDI drivers (even though, from what I recall the UNO doesn't even need them): FTDIUSBSerialDriver_v2_3.dmg

Downgraded to a prev. version of the FTDI driver hoping that would clear it up: /Volumes/FTDIUSBSerialDriver_v2_2_18

I followed a tutorial of how to remove the existing Apple drivers and removed the kext files, etc...

Tried connecting arduino to both USB ports.

Tried various cables, including the one that a I used before the Yosemite upgrade.

Tried installing updated Silabs drivers: Arduino compatible's serial port not showing Mac OSX

Walked through the entire Arduino Mac OSX guide: http://www.arduino.cc/en/guide/macOSX

After looking into the system info of my Macbook Pro, I can see the USB Controller is Broadcom based, in case that helps. I searched for Broadcom USB drivers but got hits for Silabs one instead.

Under my Tools > Port menu.. I can see these options: enter image description here clicking the Serial Ports option doesn't do anything.

Running ls -1 /dev/tty.* or ls -l /dev/tty.usb* from terminal gives me:

/dev/tty.Bluetooth-Incoming-Port
/dev/tty.Bluetooth-Modem

The Board does NOT show up under system networking (as it has for others), so it's not recognized as an incorrect device.

I'm at a complete loss. The board powers up... but I cannot connect to it.

SIDE NOTE: This is a legit Uno R3, not a clone.

  • If it is a legitimate Uno, then all of the FTDI and SiLabs efforts are an irrelevant distraction at best. Ideally, test the board and cable on an another machine to make sure it has not been damaged in the meantime, and try a different USB port on the Mac (especially try connecting through a keyboard or hub if you tried directly, or directly if you had tried a hub). I believe if you look in system information you can get a listing of all USB devices, which would be good to include in your post. – Chris Stratton May 25 '15 at 19:54
  • That's what I was thinking - regarding the FTDI drivers - but those were the only solutions I could find claiming to 'solve' this issue. I have tried other USB ports on the Macbook and will fire up my Apple keyboard since it has a USB port and reply back. I did write in my post the USB devices recognized in terminal. – revive May 25 '15 at 19:57
  • Ok, tried my Apple YSB keyboard - connecting Uno to USB port === no dice – revive May 25 '15 at 21:11
  • Moved the Apple USB Keyboard back to my iMac and tried to connect to Uno there.. selected Uno from the Board menu and still only shows bluetooth modems from the Serial Port menu. – revive May 25 '15 at 21:14
  • After updating the Arduino app to 1.6.4 the Port menu now shows the same options as my Macbook (shown in the image in Orig. Post) – revive May 25 '15 at 21:19

11 Answers 11

40

Probably, you have Chinese Uno analog which works on CH340 USB-to-serial chip, so you need to install driver for it.

Steps to fix:

  1. Install the CH340 driver
  2. Run the command in Terminal: sudo nvram boot-args="kext-dev-mode=1" (disable kext signing introduced in Mac OS X 10.9 Yosemite)
  3. Reboot

Also you're right according to Uno and FDTI:

Differences with other boards

The Uno differs from all preceding boards in that it does not use the FTDI USB-to-serial driver chip. Instead, it features the Atmega16U2 (Atmega8U2 up to version R2) programmed as a USB-to-serial converter.

  • 4
    Thanks for including the CH340 chip number right in your answer. – paperreduction Jan 9 '16 at 20:08
  • 3
    On OSX 10.11.6, installing the driver and rebooting solved this for me. No need for step 2. – hoosierEE Sep 14 '16 at 20:59
  • This worked on 10.9.4 without step 2. Now I expect my private SSH keys to be located on some chinese servers though :) – polym Nov 26 '16 at 15:02
  • 1
    If you're on Sierra, use this patched version of the driver. Worked like a charm: github.com/adrianmihalko/ch340g-ch34g-ch34x-mac-os-x-driver – Joris Oct 14 '17 at 12:00
  • 1
    @IgorGanapolsky - Starting with macOS Sierra, you must be booted to the recovery partition to run the nvram command. – Justin Lewis Feb 13 '18 at 19:55
12

The cable that shipped with my Arduino Uno worked for power but not data transmission so the /dev/tty.usbmodem was not showing up in the Tools --> Port menu. After I switched to a different cable, the /dev/tty.usbmodem port showed up and it worked beautifully.

  • 1
    The same thing happened to me. I was trying to connect my Arduino with a power-only cable. Once I switched USB cables, the USB device appeared. – hotpaw2 Jul 31 '15 at 6:04
  • I had this same problem and all it took was a different cable – Simon Apr 15 '17 at 19:15
  • This is definitely the solution for me! Thanks a ton! – tugcem May 6 '17 at 0:06
  • I have had this problem before, with Circuit Playgrounds, but forgot all about it. Switching the cable should always be the first attempt. – ow3n Jan 31 '18 at 21:43
5

This site fixed the problem for me:

http://kiguino.moos.io/2014/12/31/how-to-use-arduino-nano-mini-pro-with-CH340G-on-mac-osx-yosemite.html

...somebody else has made an alternative to the ftdi drivers, and this website show you how to install them correctly.

5

This fixed the problem for me:

http://blog.sengotta.net/signed-mac-os-driver-for-winchiphead-ch340-serial-bridge/

... and the direct link to download.

EDIT: I have one of the cheap clones with a CH340 USB chip. So this might not solve your problem, but could be beneficial to others.

  • The board in question does not have a ch340 – Chris Stratton Jan 23 '16 at 20:37
  • Cheap clones do have CH340. – Avamander Jan 24 '16 at 15:09
  • The question however, is quite specific about which board is involved, and it is quite specifically one which does not have a ch340. The poster is answering a different question than the one which was asked. – Chris Stratton Jan 25 '16 at 12:42
  • Good point. I edited my answer with a clarification. I wanted to post it anyway though, because I spent a lot of time googling for a solution to my problem and stumbled onto this thread among the rest. Maybe it'll help others. – Stefano Masini Jan 25 '16 at 16:30
  • This is the answer I was looking for, unaware that my cheap clone had a different chip from the genuine Arduino. – Johann Feb 18 '16 at 23:43
4

Yosemite 10.9 (and OS X 10.10 and newer) requires a signed USB driver kext (kernel extension). You can find one on the FTDI web site here: http://www.ftdichip.com/Drivers/VCP.htm
Use version 2.3 for 64-bit OS X 10.9 or later. Install and reboot.

Plug in your Arduino, and the Terminal command:

/usr/sbin/kextstat | grep FTDI

will tell you if the FTDI VCP driver actually loaded.

Also a /dev/tty.usbserial-xxxxxxxx entry should appear in your /dev directory.

If not, the Mac USB port isn't talking to your Arduino. So it's no use trying the Arduino IDE application.

Also make sure your USB cable isn't for power only, but fully connected.

  • 3
    Note that the Uno R3 does not use an FTDI chip. – Chris Stratton Jan 23 '16 at 20:37
3

This exact same thing happen to me on my mac running the same operating system. I had to restart this system a few times to get it to work. I restarted it with the arduino plugged in; and that worked rather than my previous attempts when i rebooted then plugged in.

  • Will try this power cycling and try again this evening.. thanks for the response! – revive May 26 '15 at 13:50
1

Check this video https://www.youtube.com/watch?v=0zuRukW7o0A

  • Reboot and press CMD+R immediately after reboot to enter in Recovery Mode
  • Open Terminal from Recovery mode
  • Run the command csrutil enable --without kext
  • Reboot
  • Install driver
0

I have an osepp r3, seemingly an accurate clone. Computer is Mac os10.10.5.

A lot of sites claimed that the mac osx.* does not require FTDI drivers, but.....

After an awkward, google searching beginning, where the board only accepted a new sketch after being physically unplugged and replugged, I downloaded the latest FTDI driver, installed, and RESTARTED the mac. Now, joy and peace reigns. No side-effects with other mac functions, thankfully. Hope this helps.

-1

Stumbled across this. It worked for Mac OS X Yosemite 10.10.5

install the CH340 driver Run the command in Terminal: sudo nvram boot-args="kext-dev-mode=1" Reboot

However, I installed: MAC system:www.wch.cn/downfile/178

so YMMV

a user here: http://forum.makeblock.cc/t/mac-os-x-yosemite-arduino-1-0-6-doesnt-recognize-makeblock-orion/728

found the solution, there: http://forum.arduino.cc/index.php?topic=261375.15

so kudos - to all that sweated out the driver, uninstall, install, and activation...

Ted

-1

In my case, there was some kind of incompatibility with the ESP8266 connected to the Nano board. As soon as I removed it the Serial Port appeared again.

  • 1
    The OP does not appear to be using a ESP8266 – Greenonline Sep 16 '15 at 22:18
-1

First, check the USB cable - I had the same problem. If you have checked it, try the HoodLoader2:

I am using it and it works with Arduino Leonardo.

  • 1
    Can you please elaborate on your answer? Link-only answers are frowned-upon. What if the link goes down? – Nick Gammon Apr 21 '16 at 21:00

protected by Community Jun 14 '17 at 5:35

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.