I have a MacBook Pro running OS X Yosemite (10.10.3). I connected my Arduino UNO R3 to my computer for the first time after the Yosemite upgrade - it worked fine before this!

When I opened the Arduino IDE I selected Tools > Board > "Arduino UNO", but when I try to choose a Serial Port the only options are:


I have followed several tutorials and threads on how to 'fix' this issue, all to no avail:

I've installed the latest version of the FTDI drivers (even though, from what I recall the UNO doesn't even need them): FTDIUSBSerialDriver_v2_3.dmg

Downgraded to a prev. version of the FTDI driver hoping that would clear it up: /Volumes/FTDIUSBSerialDriver_v2_2_18

I followed a tutorial of how to remove the existing Apple drivers and removed the kext files, etc...

Tried connecting arduino to both USB ports.

Tried various cables, including the one that a I used before the Yosemite upgrade.

Tried installing updated Silabs drivers: Arduino compatible's serial port not showing Mac OSX

Walked through the entire Arduino Mac OSX guide: http://www.arduino.cc/en/guide/macOSX

After looking into the system info of my Macbook Pro, I can see the USB Controller is Broadcom based, in case that helps. I searched for Broadcom USB drivers but got hits for Silabs one instead.

Under my Tools > Port menu.. I can see these options: enter image description here clicking the Serial Ports option doesn't do anything.

Running ls -1 /dev/tty.* or ls -l /dev/tty.usb* from terminal gives me:


The Board does NOT show up under system networking (as it has for others), so it's not recognized as an incorrect device.

I'm at a complete loss. The board powers up... but I cannot connect to it.

SIDE NOTE: This is a legit Uno R3, not a clone.

  • If it is a legitimate Uno, then all of the FTDI and SiLabs efforts are an irrelevant distraction at best. Ideally, test the board and cable on an another machine to make sure it has not been damaged in the meantime, and try a different USB port on the Mac (especially try connecting through a keyboard or hub if you tried directly, or directly if you had tried a hub). I believe if you look in system information you can get a listing of all USB devices, which would be good to include in your post. Commented May 25, 2015 at 19:54
  • 1
    1) I've checked for 'visible' USB devices in both the System Info screen and via the Terminal.. both show the same.. and only bluetooth are present (aside from keyboard and my external HDD). 2) I have now tried this on both my Mackbook Pro and my iMac .. neither of which 'see' the USB connection.
    – revive
    Commented May 25, 2015 at 22:04
  • 1
    I did. I copied the LS from Terminal as well as identified, through the system settings screen, that there are only the USB to Bluetooth, Keyboard and Internal Memory Card controller. I checked both the IDE and the System screen after: 1) changing cables, 2) adding an Apple USB keyboard and using it;s USB port, 3) trying the same sequence on my iMac (keyboard usb and main usb).. nothing. The board is not listed. Period.
    – revive
    Commented May 25, 2015 at 23:09
  • 1
    Well, looks like the board might very well be shot. I fired up my wifes Windows laptop, installed Arduino, etc.. attached power and USB to Uno and it doesn't show in either the Arduino app or File Explorer. Not sure what/how it happened as the board was stored in an air tight, dry, cool container within a static free bag - the one it shipped it. And, I'd already ran this sketch once to perfection... bummer. Any other thoughts or possibilities?
    – revive
    Commented May 26, 2015 at 0:07
  • 1
    I come back to the first question. I think I have the same problem. Basically I tried to install FTDIUSBSerialDriver v2_3.dmg on OS X Yosemite 10.10.5 The installation succeed But if I am looking in the /System/Library/Extensions/ I can see no FTDIUSBSerialDriver.kext if I go ls /dev |grep usbserial no cu.usbserial-A9GBBDLL or tty.usbserial-A9GBBDLL Please help
    – user17105
    Commented Feb 7, 2016 at 13:47

11 Answers 11


Probably, you have Chinese Uno analog which works on CH340 USB-to-serial chip, so you need to install driver for it.

Steps to fix:

  1. Install the CH340 driver
  2. Run the command in Terminal: sudo nvram boot-args="kext-dev-mode=1" (disable kext signing introduced in Mac OS X 10.9 Yosemite)
  3. Reboot

Also you're right according to Uno and FDTI:

Differences with other boards

The Uno differs from all preceding boards in that it does not use the FTDI USB-to-serial driver chip. Instead, it features the Atmega16U2 (Atmega8U2 up to version R2) programmed as a USB-to-serial converter.

  • 4
    Thanks for including the CH340 chip number right in your answer. Commented Jan 9, 2016 at 20:08
  • 3
    On OSX 10.11.6, installing the driver and rebooting solved this for me. No need for step 2. Commented Sep 14, 2016 at 20:59
  • 2
    This worked on 10.9.4 without step 2. Now I expect my private SSH keys to be located on some chinese servers though :)
    – polym
    Commented Nov 26, 2016 at 15:02
  • 1
    @polym - was the second half of your comment really necessary?
    – Colin
    Commented Jan 1, 2017 at 10:35
  • 1
    @Colin did you manage to get it working?
    – rebellion
    Commented Jan 10, 2017 at 11:38

The cable that shipped with my Arduino Uno worked for power but not data transmission so the /dev/tty.usbmodem was not showing up in the Tools --> Port menu. After I switched to a different cable, the /dev/tty.usbmodem port showed up and it worked beautifully.

  • 3
    The same thing happened to me. I was trying to connect my Arduino with a power-only cable. Once I switched USB cables, the USB device appeared.
    – hotpaw2
    Commented Jul 31, 2015 at 6:04
  • 1
    I had this same problem and all it took was a different cable
    – Simon
    Commented Apr 15, 2017 at 19:15
  • 1
    This is definitely the solution for me! Thanks a ton!
    – tugcem
    Commented May 6, 2017 at 0:06
  • I have had this problem before, with Circuit Playgrounds, but forgot all about it. Switching the cable should always be the first attempt.
    – ow3n
    Commented Jan 31, 2018 at 21:43
  • Same, I got the elegoo mega 2560 kit and the little usb c cable seemed to only work part of the time. Odd... Commented Apr 25, 2021 at 4:46

This fixed the problem for me:


... and the direct link to download.

EDIT: I have one of the cheap clones with a CH340 USB chip. So this might not solve your problem, but could be beneficial to others.

  • The board in question does not have a ch340 Commented Jan 23, 2016 at 20:37
  • Cheap clones do have CH340.
    – Avamander
    Commented Jan 24, 2016 at 15:09
  • The question however, is quite specific about which board is involved, and it is quite specifically one which does not have a ch340. The poster is answering a different question than the one which was asked. Commented Jan 25, 2016 at 12:42
  • Good point. I edited my answer with a clarification. I wanted to post it anyway though, because I spent a lot of time googling for a solution to my problem and stumbled onto this thread among the rest. Maybe it'll help others. Commented Jan 25, 2016 at 16:30
  • This is the answer I was looking for, unaware that my cheap clone had a different chip from the genuine Arduino.
    – Johann
    Commented Feb 18, 2016 at 23:43

Yosemite 10.9 (and OS X 10.10 and newer) requires a signed USB driver kext (kernel extension). You can find one on the FTDI web site here: http://www.ftdichip.com/Drivers/VCP.htm
Use version 2.3 for 64-bit OS X 10.9 or later. Install and reboot.

Plug in your Arduino, and the Terminal command:

/usr/sbin/kextstat | grep FTDI

will tell you if the FTDI VCP driver actually loaded.

Also a /dev/tty.usbserial-xxxxxxxx entry should appear in your /dev directory.

If not, the Mac USB port isn't talking to your Arduino. So it's no use trying the Arduino IDE application.

Also make sure your USB cable isn't for power only, but fully connected.

  • 3
    Note that the Uno R3 does not use an FTDI chip. Commented Jan 23, 2016 at 20:37

This site fixed the problem for me:


...somebody else has made an alternative to the ftdi drivers, and this website show you how to install them correctly.


This exact same thing happen to me on my mac running the same operating system. I had to restart this system a few times to get it to work. I restarted it with the arduino plugged in; and that worked rather than my previous attempts when i rebooted then plugged in.

  • Will try this power cycling and try again this evening.. thanks for the response!
    – revive
    Commented May 26, 2015 at 13:50

Check this video https://www.youtube.com/watch?v=0zuRukW7o0A

  • Reboot and press CMD+R immediately after reboot to enter in Recovery Mode
  • Open Terminal from Recovery mode
  • Run the command csrutil enable --without kext
  • Reboot
  • Install driver

I have an osepp r3, seemingly an accurate clone. Computer is Mac os10.10.5.

A lot of sites claimed that the mac osx.* does not require FTDI drivers, but.....

After an awkward, google searching beginning, where the board only accepted a new sketch after being physically unplugged and replugged, I downloaded the latest FTDI driver, installed, and RESTARTED the mac. Now, joy and peace reigns. No side-effects with other mac functions, thankfully. Hope this helps.


Stumbled across this. It worked for Mac OS X Yosemite 10.10.5

install the CH340 driver Run the command in Terminal: sudo nvram boot-args="kext-dev-mode=1" Reboot

However, I installed: MAC system:www.wch.cn/downfile/178


a user here: http://forum.makeblock.cc/t/mac-os-x-yosemite-arduino-1-0-6-doesnt-recognize-makeblock-orion/728

found the solution, there: http://forum.arduino.cc/index.php?topic=261375.15

so kudos - to all that sweated out the driver, uninstall, install, and activation...



In my case, there was some kind of incompatibility with the ESP8266 connected to the Nano board. As soon as I removed it the Serial Port appeared again.

  • 1
    The OP does not appear to be using a ESP8266 Commented Sep 16, 2015 at 22:18

First, check the USB cable - I had the same problem. If you have checked it, try the HoodLoader2:

I am using it and it works with Arduino Leonardo.

  • 1
    Can you please elaborate on your answer? Link-only answers are frowned-upon. What if the link goes down?
    – Nick Gammon
    Commented Apr 21, 2016 at 21:00

Not the answer you're looking for? Browse other questions tagged or ask your own question.