1

I am using Windows 8.1 64 bit. I have an Arduino Mega 2560. I configured and installed it with the Merlin firmware before. I had a system format in between. I tried to connect my Arduino again.

I have the following problems:

  1. Not detecting any hardware when plugging in the Arduino board: the green LED is on and the yellow LED is blinking. I checked the Device manager. It doesn't come in either COM ports or other devices. (The last time it came in COM ports as Arduino Uno). I installed legacy hardware on COM 3 (which was used before) and tried to update the driver from a newly downloaded version of Arduino. No success. I disabled the certification signature requirement from boot menu and tried: again no success.

  2. The serial port on Arduino is greyed out.

I need some help. I am running out of ideas. I tried uninstalling COM port. I cleaned the registry with CCleaner. I uninstalled all Arduino software. I rebooted the system. I downloaded everything again, then connected the board. Still not detecting the new hardware. :P

Help me out.

5
  • 2
    Step 1: try it in someone else's computer to see if it's your computer or the Arduino that is at fault.
    – Majenko
    May 20, 2015 at 10:29
  • its not reading at any other computer as well. Tried using different usb cables as well no success May 20, 2015 at 19:18
  • Then chances are it's the Mega that is at fault. I have seen a number of posts recently about Arduinos failing to be recognised by the PC - maybe there is something going wrong with the USB interface common to them all. All I can suggest is try re-flashing the USB interface microcontroller (ATMega16U2 IIRC) with a new firmware.
    – Majenko
    May 20, 2015 at 21:28
  • can you confirm if the previous program you uploaded is still running? Aug 20, 2015 at 6:45
  • A useful reference for troubleshooting (most tips apply to the Mega as well as the Uno) arduino.stackexchange.com/questions/13292/… May 14, 2017 at 0:04

3 Answers 3

1

What you said has happened to me before.This happened to me as I supplied over 20v to the arduino.Did you supply a higher voltage than recommended or pull too many amps from the board?If you did so,it is almost futile to try to repair it.

1

Assuming the board is not fried...

Sounds like 'USB <--> serial' chip issue. Not sure which chip it is, could be CP2102 or FT232 or CH340G. If it is FT232R and not a genuine one and you are using a specific version of the driver - you could have bricked the USB <--> serial converter.

Without assumptions, I would start with a bootable USB pen-drive with some flavour of Linux - I prefer Linux Mint/Ubuntu. Here is how I would go:

  1. Boot the system with the pen-drive with Arduino disconnected
  2. Open terminal and tail the system log (e.g. tailf /var/log/syslog)
  3. Attach the Arduino board and see what shows up.
  4. If Arduino is detected, there will be a message with the serial port device name (e.g. /dev/ttyUSB0)
  5. Arduino IDE could run on Linux. If the port is detected, run Arduino IDE and see if it detects the board.

If not detected, the board is still useable, but you might need to find a way to connect external USB <--> Serial converter and disconnect the on board one. That means cutting traces and probably soldering some pins.

1

It's possible it's fried - but I have had recovered some boards like this that the boot software had gotten corrupted. It's easy enough to reapply the bootloader to the device - you will need either a second arduino:

https://www.arduino.cc/en/Tutorial/ArduinoISP

or an usbasp programmer (about $10 on eBay).

There is also a tutorial on reflashing the USB chip (link below) - but I would try the above first.

https://www.virtuabotix.com/how-to-cure-sudden-uno-death-syndrome/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.