0

Sorry about my English.

I'm a new bie in program Arduino and interested in ESP8266. I'm trying to use ESP8266 control Arduino Yun using REST API.

Like you know, we using web browser as

http://<Arduino_Yún_Address>/arduino/<status>/<pin>/<value(optional)>

Example: http://<Arduino_Yún_Address>/arduino/digital/13/1

you bring pin 13 to high, by closing the relay and giving light to the LED,

while with: http://<Arduino_Yún_Address>/arduino/digital/13/0

the relay is opened and the LED is turned off

and I want to use ESP8266 to send command like using web browser and it didn't work.

After connect to Wifi access point and Server of Yun done, I've tried to send command like

GET /http://<Arduino_Yún_Address>/arduino/digital/13/1

Please give me some idea or move advices about this situation. Thanks for reading my topic. :D

Here is my problem:

AT+CIPSTART="TCP","192.168.0.150",80


OK
Linked
AT+CIPSEND=58

> GET /http://192.168.0.150/arduino/digital/13/1 HTTP/1.0\n

wrong syntax

ERROR
  • The syntax depends on the firmware you're using. Are you using multiplexing? Have you tried if AT+CIPSEND=0,58 also returns "wrong syntax"? – fuenfundachtzig May 9 '15 at 8:38
  • Did any one manage to find a solution to this problem ?? – Alok Jan 17 '16 at 13:19
  • While your approach is good, you haven't provide a sketch and a schematic to work with. – user31481 Oct 28 '17 at 23:10
1

The proper HTTP request should look like:

GET /arduino/digital/13/1 HTTP/1.0\r\n

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.