0

I'm about to ask a question for the most common problem which everyone has with attiny85 and the IR library. I will try to make this question as simple as possible.

Few things about the lib and the chip

First of all the lib https://github.com/shirriff/Arduino-IRremote works great on the UNO and it's the best out there.

The Attiny85 is the smallest chip you can get able to run Arduino code. It has alot of limitations but it worth it!

The common problem

Attiny85 uses different timers from the normal Attiny and Atmega chips which makes it impossible to run the standard libraries. There are some fixes for some libs. For example the IR Remote has a version which ALMOST works with the chip and it can be found over here: http://gammon.com.au/Arduino/IRremote_Attiny.zip

However the problem lies in the core. The first time i used the patched IR i had the MIT High Low Media Group versino 1 of the core files which bearly worked but it was the first released so...

After reading this guide:http://www.instructables.com/id/Attiny-IR-library/?ALLSTEPS I used an updated core which can be found here: https://arduino-tiny.googlecode.com/files/arduino-tiny-0100-0017.zip

And the final problem

Even with the updated core i still got only 1 last error.

Compiling 'Shit' for 'ATtiny85 @ 8 MHz  (internal oscillator; BOD disabled)'
IRremoteInt.h:101: error: 'RAWBUF' was not declared in this scope
Error compiling

Does anyone know how to fix it?

Links

  1. MIT high-low group first version: http://highlowtech.org/?p=1229
  2. Tutorial for the chip and the IR: http://www.instructables.com/id/Attiny-IR-library/?ALLSTEPS
  3. The IR original lib: https://github.com/shirriff/Arduino-IRremote
  4. Updated core: https://arduino-tiny.googlecode.com/files/arduino-tiny-0100-0017.zip

Just in case you wanna know i'm using the Atmel Studio 6 with the Visual Micro plugin instead of the crappy-arduino-IDE

1

RAWBUF is defined in IRremote.h. Make sure you include that header before including IRremoteInt.h.

  • it worked but not im getting this: Upload failed. Did you select the correct upload method for this board? System.Collections.Generic.KeyNotFoundException: The given key was not present in the dictionary. at System.Collections.Generic.Dictionary`2.get_Item(TKey key) at processing.app.debug.AvrdudeUploader.uploadUsingPreferences(String buildPath, String className, Boolean verbose, Boolean ProgrammerUploadUsing, String mcuProgrammerOverrideName) at processing.app.SketchEditor.Upload(Boolean verbose) – Meletis Flevarakis May 4 '15 at 21:18
  • That's a problem with your build environment, not the code. – Ignacio Vazquez-Abrams May 4 '15 at 21:18
  • Indeed. I upload it through the IDE and its working however the receiver is just dead. nothinf happens when i press the button – Meletis Flevarakis May 4 '15 at 21:48
  • Keep your Visual Micro up to date and the error above will not appear :) – Visual Micro Jul 3 '15 at 14:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.