-1

So I just got this board I ordered from ebay and tried to play with it for the first time. http://www.ebay.com/itm/Leonardo-Pro-Micro-ATmega32U4-Arduino-IDE-1-0-3-Bootloader-replace-Pro-Mini-/310634777706?pt=LH_DefaultDomain_0&hash=item4853468c6a

I connected it to my PC and it was installing a driver. I didn't pay much attention to it but I think it finished installing it successfully. I then installed arduino IDE 1.6.3(latest) and tried to compile and upload the empty default sketch just to see if it uploads it. the progress bar got to the end but it was stuck on "uploading..". I waited for a few minutes but it didn't seem like it is going to end so I unplugged the USB and re inserted it back. I then looked in the tools menu and saw it was set to port COM1 which is the communications port on my pc, so I changed it to port COM4(Arduino Leonardo) and the board to Leonardo and again tried to compile and upload the default sketch but now I got this error:

Arduino: 1.6.3 (Windows 7), Board: "Arduino Leonardo"

Error opening serial port 'COM4'. (Port not found)

trying to open the serial monitor gives the same error.

So I checked the item listing on ebay and it said that the board was supported under arduino IDE 1.0.3 so I downloaded it and tried to compile and upload the default sketch but it gave me the serial port 'COM4' already in use error.

I tried resetting the board, uninstalling and reinstalling the driver and the IDEs and disabling/re-enabling the device in the device manager. nothing helped.

I am not sure what I am doing wrong as I am new to this.

Thank you.

1

Reboot you PC, see if that clears it.

If not then fire up Device Manager and have a look at what COM ports you are using.

I think there is a way of reassigning the ports used by the boards within the control panel, but I can't remember what it is at the moment, so have a quick google.

Its not the fact that its a Clone that's causing you an issue, its Windows drivers that have caused you issues. If all else fails, uninstall the drivers, reboot twice and try again. I also don't think using a newer version of the IDE will have a negative affect.

  • 1
    I had already solved that issue months ago though I forgot to comeback and add an answer... I don't remember what I did exactly but it worked since then. I think I just played around with the USB ports trying to connect it in different ones until I got it to work but I am not 100% sure. – Jake Jan 15 '16 at 6:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.