0

my project involves 9 Neopixel LEDs. I have tested my code with my Arduino Uno board successfully. I'm using a mix of breadboard, jumper wires, and solder to connect everything. Powering the strip of 9 LEDs with 4 AA NiMh rechargable batteries, showing 5.2v on the meter. I've put a capacitor (1000mF 25v) in the circuit, right at the power source.

But when I upload the same code to my Mini (5v/16MHz) and swap it in in place of the Uno, I get nothing. No matter how much I jiggle wires or provide a good ground (which helped me get good results from my Uno). Every now and then by messing with wires, or as a few minutes go by, the first few lights might light up, but not in the right colors and no animation.

Just to test the Mini board I uploaded the sample program "blink" and the mini runs that one properly. So I'm certain my code is getting on there. My program is definitely bigger and involves some quick changes (I'm making an "ebbing" glow of supernatural eyes). Connecting the Mini to the Neopixel strip I soldered a wire with a female jumper onto the board, and my strip of lights has a wire soldered on with a male jumper. As a side note, it takes a little physical handling to get the project to work with the Uno (like pressing a little bit on the data wire in it's plug on the Uno or using a jumper wire in the breadboard clamped in a metal measuring tool and my hand to ground out the circuit). So maybe I'm just experiencing some of the shortcomings of the Mini, but I was under the impression that it would do just about anything the Uno could do. Especially in terms of just providing a data line for the LEDs.

I'm new to Neopixel. This is my first project in fact. So it is entirely possible I'm doing something wrong or there's something I just missed completely, or maybe my luck just sucks and I have some piece of faulty hardware... No idea.

Any suggestions would be most appreciated!

  • For debugging your hardware (which sounds like the problem), use a simple sketch that just turns on one Neopixel after another, and power it from the wall instead of batteries. – James Waldby - jwpat7 Apr 28 '15 at 16:10
  • I'll give that a shot! I'll whip up a quick and simple sketch tonight like you mentioned and see if I get some results. – Tony M Apr 29 '15 at 2:16
  • Ugh. Don't know what's going on. I made a simple program, tried it, and nothing happens. I load up the program in my Uno, works fine. Tried soldering some connectors to another mini (I bought 3 of them) and nothing. The struggle continues... Still in the dark as to why. I just watched a video of someone lighting up a string of 144 lights with animation using a mini. So I know this is supposed to work. Oh well. Thanks for the suggestion, jwpat7. I'll continue troubleshooting. – Tony M May 7 '15 at 2:33
  • Some random ideas to check: Are there ATmega328 chips on both your Uno and your Mini Pro? (Ie are the processors the same on both, as one would expect?) Have you verified +5V on all the +5V pins? Perhaps post a closeup photo or two, in your question, in case of some wiring error like hooking unregulated power to Vcc, or regulated power to Raw (which conceivably might work ok with the Blink program but not with something that requires more current). – James Waldby - jwpat7 May 7 '15 at 5:42
  • A quick glance at the boards confirmed they both have the Mega328 printed on them. I'll check voltages at each pin tonight and snap some pics when I get the chance later. Watching the YouTube video I also noticed that the light on the mini was either green or blue couldn't tell with the quality of the vid. My minis have both shown solid red on the boards. I assumed that meant "power on". Maybe it means there is a problem with power? It also occured to me that the board may not like running off of USB power through the FTDI adapter. – Tony M May 7 '15 at 7:34
1

As I was playing around today I found a solution. Powering the board through the FTDI adapter, which in turn was being powered by a USB juicepack charger, wasn't supplying enough juice and/or ground. It was enough for the Uno to work, so that's what was confusing me. I soldered in a 9V battery and clamped down on the pins with a wrench to ground it out. That made the board happy and it kicked into gear and lit my project up perfectly. It's pretty ghetto but it works! Yeah! :Denter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.