0

I have an Arduino Uno which communicated with the computer (Ubunutu 14.04) fine till 6 days ago (I assume some software update is to blame).

Now when trying to upload I get

processing.app.SerialNotFoundException: Serial port '/dev/ttyACM0' not found. Did you select the right one from the Tools > Serial Port menu? at processing.app.Serial.(Serial.java:191) at processing.app.Serial.(Serial.java:77) at processing.app.debug.Uploader.flushSerialBuffer(Uploader.java:77) at processing.app.debug.AvrdudeUploader.uploadViaBootloader(AvrdudeUploader.java:175) at processing.app.debug.AvrdudeUploader.uploadUsingPreferences(AvrdudeUploader.java:67) at processing.app.Sketch.upload(Sketch.java:1671) at processing.app.Sketch.exportApplet(Sketch.java:1627) at processing.app.Sketch.exportApplet(Sketch.java:1599) at processing.app.Editor$DefaultExportHandler.run(Editor.java:2380) at java.lang.Thread.run(Thread.java:745)

When I sudo ls /dev/ttyA*

I get

ls: cannot access /dev/ttyA*: No such file or directory

So it does not look like a permission issue.

when I lsusb

I get

Bus 001 Device 002: ID 8087:8000 Intel Corp. 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 002 Device 003: ID 04f2:b39a Chicony Electronics Co., Ltd 
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

So it does not even see the device (which is connected and pulling current).

when I dmesg before and after connecting the Arduino, I don't see anything new.

I tried switching USB cables, and switching USB ports on the machine (both ports work with a mouse), but in vain.

What went wrong and how do I fix it ?

Thanks, David.

  • Can you try the Arduino on someone else's computer? – Majenko Apr 17 '15 at 17:33
  • @Majenko I tried on my wife's Mac and it didn't work, but I only installed the software on that machine for the purpose of the troubleshooting, so I still have hope that I did something wrong on it; I say "hope" because currently the leading options I see are: 1) something bad happened to the USB controller, 2) two faulty cables (that one is hard to believe) – David Lehavi Apr 17 '15 at 18:40
  • Does the power light illuminate? Does the LED on pin 13 blink a couple of times when you first connect it? – Majenko Apr 17 '15 at 18:42
  • 1
    The next step would be to try to access the USB comm chip out of band. You wouldn't happen to have a AVR ISP programmer or a second, working Arduino, would you? – Ignacio Vazquez-Abrams Apr 17 '15 at 18:46
  • 1
    Follow the ArduinoISP tutorial and hook it up to the 6-pin connector near the small chip (Atmega16U2) closest to the USB connector, then use avrdude to try and communicate with the chip. – Ignacio Vazquez-Abrams Apr 17 '15 at 18:51
2

Ok, it sounds like there is an issue with the ATMega(8/16)U2 chip or its surroundings. It might just need its firmware refreshing (which can be done with another Arduino as a programmer) or it might be plain dead.

Another possibility is the USB socket itself. I have two UNOs, one which is perfectly fine, and one where I need to hold the cable at just the right angle for it to connect properly. You can try using a fine needle to try and raise the four metal strips in the USB connector a fraction to make better contact.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.