1

I purchased a half dozen fake Arduinos hoping to build a bunch of projects without paying a fortune. I have all the drivers installed, and the port shows up in the Arduino IDE. The problem is when I try and upload the code I get the following error:

can't open device "/dev/cu.wch": No such file or directory

I played around a little and tried running:

sudo ln -s cu.wch\ ch341\ USB\=\>RS232\ 1a1220  cu.wch

After running this a new port shows up called cu.wch, and if I select that it works.

The issue is the Arduino's port is cu.wch ch341 USB=>RS232 1a1220, but for some reason the IDE is trying to write to cu.wch. By linking the folders I can fix this but since it is a hack every time I restart my computer I have to rerun the command. Is there a way I can either rename the Arduino port or permanently link the folder?

I am using OSX 10.10 and Arduino IDE v1.6.3

1

I would guess the problem is the IDE not properly handling device names containing spaces. Consider your symlink a workaround rather than a hack - unless you want to repair the IDE itself.

-1

You must download the CH431 drivers to your computer and restart. This will solve your problem. Google these drivers, you should be able to find them. If not, let me know and I can send you a link to my drive.

  • Already did that. Please note as I mentioned I am using OSX 10.10.2 Yosemite. Before 10.10 (Mavericks) this solution would have worked, but the update seems to have broken this method. Please read my question carefully where I said "I have all the drivers installed". – user8452 Apr 29 '15 at 2:19
-2

I am not familiar with OS X but in the Arduino IDE you can select the port by going to Tools-->Port and select the appropriate port. To find the appropriate port you would have to go into the Windows equivalent of the Device Manager.

EDIT

The documentation from the official site might help.

  • That is not the problem. I selected the right port cu.wch ch341 USB=>RS232 1a1220, but for some reason when I go to upload it tries to use cu.wch. I was able to fix this by creating a symlink to a fake port named cu.wch, which points to the real port, and selecting that. I would like to fix the issue rather than applying a hack. – user8452 Apr 16 '15 at 19:19
  • Try the site in my edited answer. – NULL Apr 16 '15 at 19:27
  • 1
    You do not get what I am saying. This is not an easy issue or something that I am doing wrong. It is a problem related to the fact that I am using "fake Arduinos" and the port not matching up with the name of the device. – user8452 Apr 16 '15 at 19:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy