1

I have my Arduino Nano connected to the HC-06 module (with the RX/TX pins).

My issue is that when I try to upload new code to my Arduino (via the Arduino IDE, through the USB connection) the Arduino IDE doesn't succeed.

I get this error:

avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0x00

I believe that it is just trying to upload the code to the HC-06 (instead of the Arduino). Is there a way to overcome this issue?.

Thanks.

Note: I found this entry https://stackoverflow.com/questions/27175937/arduino-program-upload-while-btooth-module-connected-avrdude-stk500-getsync indicating that it wasn't possible (that I need to unplug the module). I am trying to confirm it.

marked as duplicate by Anonymous Penguin May 21 '15 at 23:25

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Your code might not work on leonardos/micros, but in any case they don't use pins 0 and 1 to upload so I believe you should be able to upload while the HC-06 is plugged in with either of those. – BrettAM Apr 16 '15 at 3:45
  • 1
    You might be able to electrically "remove" the blueooth module if it has a distinct reset line you can hold asserted, but unplugging it would be conceptually simplest. – Chris Stratton Apr 17 '15 at 3:52
2

The link in question was correct... you do need to unplug it.

The Arduino's serial chip uses pins 0 and 1 to communicate with the ATmega 328 PU chip onboard, thus you have two independent devices connected to the same wires and both the Arduino main chip and the Bluetooth module are trying to communicate at the same time (rendering all data unreadable by the computer).

Not the answer you're looking for? Browse other questions tagged or ask your own question.